$re = '/^(?:(?:\d{2}:\d{2}\-\d{2}:\d{2})(?:,(?!$))?)*$/m';
$str = '09:00-10:00,12:00-14:30,16:00-18:00
09:00-10:00,12:00-14:30,
09:00-10:00
09:00-10:00,
09:00
09:00-10:00-12:00-14:30,16:00-18:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);