re = /^(?:(?:\d{2}:\d{2}\-\d{2}:\d{2})(?:,(?!$))?)*$/m
str = '09:00-10:00,12:00-14:30,16:00-18:00
09:00-10:00,12:00-14:30,
09:00-10:00
09:00-10:00,
09:00
09:00-10:00-12:00-14:30,16:00-18:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end