package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*#.*`)
var str = `1.6 # blah blah blah
# fjsadfklj slkjf yes 3.4
1.8*
1.9 1.10 #blah
#blah
1.11`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}