re = /\s*#.*/m
str = '1.6 # blah blah blah
# fjsadfklj slkjf yes 3.4
1.8*
1.9 1.10 #blah
#blah
1.11'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result