#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-_a-zA-Z.+!%0-9]{2,}@[a-zA-Z0-9]{2,}\.[a-zA-Z.]{2,}"
Local $sString = "VALID MAILS:" & @CRLF & _
"blabla-111_29292@gmai23l.com" & @CRLF & _
"johndoe@domainsample.com" & @CRLF & _
"john.doe@domainsample.net" & @CRLF & _
"john.doe43@domainsample.co.uk" & @CRLF & _
"testteoijtwet@coco.co.uk" & @CRLF & _
"" & @CRLF & _
"INVALID MAILS:" & @CRLF & _
"@domainsample.com" & @CRLF & _
"johndoedomainsample.com" & @CRLF & _
"john.doe@.net" & @CRLF & _
"john.doe43@domainsample" & @CRLF & _
"john.doe@toto."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")