// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[-_a-zA-Z.+!%0-9]{2,}@[a-zA-Z0-9]{2,}\.[a-zA-Z.]{2,}").unwrap();
let string = "VALID MAILS:
blabla-111_29292@gmai23l.com
johndoe@domainsample.com
john.doe@domainsample.net
john.doe43@domainsample.co.uk
testteoijtwet@coco.co.uk
INVALID MAILS:
@domainsample.com
johndoedomainsample.com
john.doe@.net
john.doe43@domainsample
john.doe@toto.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}