package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-_a-zA-Z.+!%0-9]{2,}@[a-zA-Z0-9]{2,}\.[a-zA-Z.]{2,}`)
var str = `VALID MAILS:
blabla-111_29292@gmai23l.com
johndoe@domainsample.com
john.doe@domainsample.net
john.doe43@domainsample.co.uk
testteoijtwet@coco.co.uk
INVALID MAILS:
@domainsample.com
johndoedomainsample.com
john.doe@.net
john.doe43@domainsample
john.doe@toto.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}