import Foundation
let pattern = #"[-_a-zA-Z.+!%0-9]{2,}@[a-zA-Z0-9]{2,}\.[a-zA-Z.]{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VALID MAILS:
blabla-111_29292@gmai23l.com
johndoe@domainsample.com
john.doe@domainsample.net
john.doe43@domainsample.co.uk
testteoijtwet@coco.co.uk
INVALID MAILS:
@domainsample.com
johndoedomainsample.com
john.doe@.net
john.doe43@domainsample
john.doe@toto.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)