using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-_a-zA-Z.+!%0-9]{2,}@[a-zA-Z0-9]{2,}\.[a-zA-Z.]{2,}";
string input = @"VALID MAILS:
blabla-111_29292@gmai23l.com
johndoe@domainsample.com
john.doe@domainsample.net
john.doe43@domainsample.co.uk
testteoijtwet@coco.co.uk
INVALID MAILS:
@domainsample.com
johndoedomainsample.com
john.doe@.net
john.doe43@domainsample
john.doe@toto.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}