$re = '/[-_a-zA-Z.+!%0-9]{2,}@[a-zA-Z0-9]{2,}\.[a-zA-Z.]{2,}/m';
$str = 'VALID MAILS:
blabla-111_29292@gmai23l.com
johndoe@domainsample.com
john.doe@domainsample.net
john.doe43@domainsample.co.uk
testteoijtwet@coco.co.uk
INVALID MAILS:
@domainsample.com
johndoedomainsample.com
john.doe@.net
john.doe43@domainsample
john.doe@toto.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);