import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[-_a-zA-Z.+!%0-9]{2,}@[a-zA-Z0-9]{2,}\\.[a-zA-Z.]{2,}";
final String string = "VALID MAILS:\n"
+ "blabla-111_29292@gmai23l.com\n"
+ "johndoe@domainsample.com\n"
+ "john.doe@domainsample.net\n"
+ "john.doe43@domainsample.co.uk\n"
+ "testteoijtwet@coco.co.uk\n\n"
+ "INVALID MAILS:\n"
+ "@domainsample.com\n"
+ "johndoedomainsample.com\n"
+ "john.doe@.net\n"
+ "john.doe43@domainsample\n"
+ "john.doe@toto.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}