#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[img\](.+)\[/img\]"
Local $sString = "[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]"
Local $sSubst = "<img src=${1}>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)