use strict;
my $str = '[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]';
my $regex = qr%\[img\](.+)\[/img\]%p;
my $subst = '<img src=${1}>';
my $result = $str =~ s%$regex%$subst%r;
print "The result of the substitution is' $result\n";