const regex = new RegExp('\\[img\\](.+)\\[/img\\]', '')
const str = `[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]`;
const subst = `<img src=${1}>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);