package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[img\](.+)\[/img\]`)
var str = []byte(`[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]`)
var substitution = []byte("<img src=${1}>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}