import re
regex = re.compile(r"\[img\](.+)\[/img\]")
test_str = "[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]"
subst = "<img src=${1}>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)