using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[img\](.+)\[/img\]";
string substitution = @"<img src=${1}>";
string input = @"[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}