$re = '%\[img\](.+)\[/img\]%';
$str = '[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]';
$subst = "<img src=${1}>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;