const regex = /(^(\-?)((([1-9]([0-9]{0,11}))?)|0)(\.)([0-9]){0,12}$)|(^(\-?)([0-9]){0,12}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(\\-?)((([1-9]([0-9]{0,11}))?)|0)(\\.)([0-9]){0,12}$)|(^(\\-?)([0-9]){0,12}$)', 'gm')
const str = `2
3.87
636
4
3e7
-190.33
12345678.
-45
-0.343
-3030
0.999
.25
0.36
g
t555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}