import re
regex = re.compile(r"(^(\-?)((([1-9]([0-9]{0,11}))?)|0)(\.)([0-9]){0,12}$)|(^(\-?)([0-9]){0,12}$)", flags=re.MULTILINE)
test_str = ("2\n"
"3.87\n"
"636\n"
"4\n"
"3e7\n"
"-190.33\n"
"12345678.\n"
"-45\n"
"-0.343\n"
"-3030\n"
"0.999\n"
".25\n"
"0.36\n"
"g\n"
"t555")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")