import Foundation
let pattern = #"(^(\-?)((([1-9]([0-9]{0,11}))?)|0)(\.)([0-9]){0,12}$)|(^(\-?)([0-9]){0,12}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2
3.87
636
4
3e7
-190.33
12345678.
-45
-0.343
-3030
0.999
.25
0.36
g
t555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)