use strict;
my $str = '2
3.87
636
4
3e7
-190.33
12345678.
-45
-0.343
-3030
0.999
.25
0.36
g
t555';
my $regex = qr/(^(\-?)((([1-9]([0-9]{0,11}))?)|0)(\.)([0-9]){0,12}$)|(^(\-?)([0-9]){0,12}$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}