re = /(^(\-?)((([1-9]([0-9]{0,11}))?)|0)(\.)([0-9]){0,12}$)|(^(\-?)([0-9]){0,12}$)/m
str = '2
3.87
636
4
3e7
-190.33
12345678.
-45
-0.343
-3030
0.999
.25
0.36
g
t555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end