import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^h[1,3,5]-f5(?:lb|gtm)01-s\\.eset\\.com$";
final String string = "h1-f5lb01-s.eset.com\n"
+ "h1-f5gtm01-s.eset.com\n\n"
+ "h3-f5lb01-s.eset.com\n"
+ "h3-f5gtm01-s.eset.com\n\n"
+ "h5-f5lb01-s.eset.com\n"
+ "h5-f5gtm01-s.eset.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}