use strict;
my $str = 'h1-f5lb01-s.eset.com
h1-f5gtm01-s.eset.com
h3-f5lb01-s.eset.com
h3-f5gtm01-s.eset.com
h5-f5lb01-s.eset.com
h5-f5gtm01-s.eset.com';
my $regex = qr/^h[1,3,5]-f5(?:lb|gtm)01-s\.eset\.com$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}