import Foundation
let pattern = #"^h[1,3,5]-f5(?:lb|gtm)01-s\.eset\.com$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
h1-f5lb01-s.eset.com
h1-f5gtm01-s.eset.com
h3-f5lb01-s.eset.com
h3-f5gtm01-s.eset.com
h5-f5lb01-s.eset.com
h5-f5gtm01-s.eset.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)