re = /^h[1,3,5]-f5(?:lb|gtm)01-s\.eset\.com$/mi
str = 'h1-f5lb01-s.eset.com
h1-f5gtm01-s.eset.com
h3-f5lb01-s.eset.com
h3-f5gtm01-s.eset.com
h5-f5lb01-s.eset.com
h5-f5gtm01-s.eset.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end