// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^h[1,3,5]-f5(?:lb|gtm)01-s\.eset\.com$").unwrap();
let string = "h1-f5lb01-s.eset.com
h1-f5gtm01-s.eset.com
h3-f5lb01-s.eset.com
h3-f5gtm01-s.eset.com
h5-f5lb01-s.eset.com
h5-f5gtm01-s.eset.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}