using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(HREF=""http[s]?:\/\/)(?'hostname1'(.*?))[:|\/|""].*?\""\>(http[s]?:\/\/)(?'hostname2'\k<hostname1>)[<|\/|:]";
string input = @"<A HREF=""http://phishers.org/we_want_your_money.htm"">http://phishers.org/somewhere </A>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}