$re = '/(HREF="http[s]?:\/\/)(?\'hostname1\'(.*?))[:|\/|"].*?\"\>(http[s]?:\/\/)(?\'hostname2\'\k<hostname1>)[<|\/|:]/';
$str = '<A HREF="http://phishers.org/we_want_your_money.htm">http://phishers.org/somewhere </A>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);