const regex = /(HREF="http[s]?:\/\/)(?'hostname1'(.*?))[:|\/|"].*?\"\>(http[s]?:\/\/)(?'hostname2'\k<hostname1>)[<|\/|:]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(HREF="http[s]?:\\\/\\\/)(?\'hostname1\'(.*?))[:|\\\/|"].*?\\"\\>(http[s]?:\\\/\\\/)(?\'hostname2\'\\k<hostname1>)[<|\\\/|:]', '')
const str = `<A HREF="http://phishers.org/we_want_your_money.htm">http://phishers.org/somewhere </A>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}