package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(HREF="http[s]?:\/\/)(?'hostname1'(.*?))[:|\/|"].*?\"\>(http[s]?:\/\/)(?'hostname2'\k<hostname1>)[<|\/|:]`)
var str = `<A HREF="http://phishers.org/we_want_your_money.htm">http://phishers.org/somewhere </A>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}