import Foundation
let pattern = #"(HREF="http[s]?:\/\/)(?'hostname1'(.*?))[:|\/|"].*?\"\>(http[s]?:\/\/)(?'hostname2'\k<hostname1>)[<|\/|:]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<A HREF="http://phishers.org/we_want_your_money.htm">http://phishers.org/somewhere </A>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}