import re
regex = re.compile(r"(HREF=\"http[s]?:\/\/)(?'hostname1'(.*?))[:|\/|\"].*?\"\>(http[s]?:\/\/)(?'hostname2'\k<hostname1>)[<|\/|:]")
test_str = "<A HREF=\"http://phishers.org/we_want_your_money.htm\">http://phishers.org/somewhere </A>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")