re = /(HREF="http[s]?:\/\/)(?'hostname1'(.*?))[:|\/|"].*?\"\>(http[s]?:\/\/)(?'hostname2'\k<hostname1>)[<|\/|:]/
str = '<A HREF="http://phishers.org/we_want_your_money.htm">http://phishers.org/somewhere </A>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end