# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\h)([A-Z])\w+/\1./gm;t' <<< "John Smith
John Doe
Kim Jong Un
David X. Cohen
Bob"