use strict;
my $str = 'John Smith
John Doe
Kim Jong Un
David X. Cohen
Bob';
my $regex = qr/(?<=\h)([A-Z])\w+/mp;
my $subst = '\\1.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";