re = /(?<=\h)([A-Z])\w+/m
str = 'John Smith
John Doe
Kim Jong Un
David X. Cohen
Bob'
subst = '\\1.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result