import Foundation
let pattern = #"(?<=\h)([A-Z])\w+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
John Smith
John Doe
Kim Jong Un
David X. Cohen
Bob
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)