using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\h)([A-Z])\w+";
string substitution = @"\1.";
string input = @"John Smith
John Doe
Kim Jong Un
David X. Cohen
Bob";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}