$re = '/(?<=\h)([A-Z])\w+/m';
$str = 'John Smith
John Doe
Kim Jong Un
David X. Cohen
Bob';
$subst = "\1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;