const regex = /(?<=\h)([A-Z])\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\h)([A-Z])\\w+', 'gm')
const str = `John Smith
John Doe
Kim Jong Un
David X. Cohen
Bob`;
const subst = `\1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);