# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<pre class=("[^"]+") name="code">/[$1]/;t' <<< "<pre class=\"ruby\" name=\"code\">source :rubygems"