import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<pre class=(\"[^\"]+\") name=\"code\">";
final String string = "<pre class=\"ruby\" name=\"code\">source :rubygems";
final String subst = "[$1]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}