#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<pre class=("[^"]+") name="code">"
Local $sString = "<pre class="ruby" name="code">source :rubygems"
Local $sSubst = "[$1]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)