import re
regex = re.compile(r"<pre class=(\"[^\"]+\") name=\"code\">")
test_str = "<pre class=\"ruby\" name=\"code\">source :rubygems"
subst = "[$1]"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)