using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<pre class=(""[^""]+"") name=""code"">";
string substitution = @"[$1]";
string input = @"<pre class=""ruby"" name=""code"">source :rubygems";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}