const regex = /<pre class=("[^"]+") name="code">/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<pre class=("[^"]+") name="code">', '')
const str = `<pre class="ruby" name="code">source :rubygems`;
const subst = `[$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);