re = /<pre class=("[^"]+") name="code">/
str = '<pre class="ruby" name="code">source :rubygems'
subst = '[$1]'
result = str.sub(re, subst)
# Print the result of the substitution
puts result