using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]+)(\s+)?(?=mA)";
string input = @"case 1, only number and unit: 1mA
case 2, number and unit, space: 1mA current
case 3, number and unit, punctuation: 1mA,
case 4, number and unit, Unicode characters: 1mA电流I
case 1, only number and unit: 10mA
case 2, number and unit, space: 100mA current
case 3, number and unit, punctuation: 10 mA ,
case 4, number and unit, Unicode characters: 1000 mA电流I ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}